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Add an Appointment

There are several ways to add an appointment or message. One way is to highlight the desired time slot 
in the day planner and double click the mouse button or press enter. Alternatively you may click the Add 
button at the bottom of the screen, or select Add from the Edit Menu.

Any of these options will open the Add A Message dialog box.

Here you may enter a Message, use the Category Selection to select the Category, select a Frequency, a
Priority if it is a non-appointment, enter the starting and ending dates, appointment time, and Alarm time. 
Click on the Select Date button for help with Date Selection. The Select Time button assists you in Time 
Selection. You may also add or modify a Note by clicking the Add Note or Modify Note button. To delete a 
note click the Delete Note button.

After having entered the required information, click the Ok button to save the new appointment. Click 
Cancel to stop this procedure.

Related Topics

Delete an Appointment
Modify an Appointment
Reschedule an Appointment



Alarm

Alarms are used to remind you of an appointment or event. OnTime will sound an alarm and display the 
appropriate message even if you happen to be working in another program.

The Appointment Settings option in the Options Menu allows you to select the desired alarm tune.

The alarm may be set from within either the Add a Message or Modify a Message dialog boxes. First turn 
on the Alarm and then select the number of minutes prior to the event you wish the alarm to sound. Enter 
0 minutes to have the alarm sound at the appointment time.

An appointment with an alarm attached will have the alarm symbol  to the left of the appointments time.

When the alarm sounds a box appears displaying the appointment message, and time. To turn off the 
alarm click the Off button. Clicking the Snooze button will turn off the alarm and sound it later.
Related Topics

Add an Appointment
Day Planner
Modify an Appointment



Appointment Settings

Selecting this menu option displays the Appointment Settings dialog box. Here you may customize some 
of OnTime's features.

In the Start Time and End Time fields, enter the hours you wish OnTime to display initially. Of course, you 
may still add or manipulate appointments for the entire day if you desire.

The Alarm Tune pick list allows you to select the Alarm you wish to hear. You may try any alarm by 
selecting it and then clicking the Test Tune box. Click it again to turn the alarm off.

When exiting the program, OnTime can warn you if alarms are set that you might miss. To enable or 
disable this option, click on the Confirm exit when alarms active box.

Units are the time slots shown on the OnTime Day Planner. You may select 15 minute, 30 minute, or 60 
minute increments.

Once you have completed the customization, click the Ok button to accept the changes or Cancel to 
ignore them.

Related Topics

Color Customization
Display Settings
Font Selection



Archive Messages

The Archive Messages box displays archived messages retrieved with the archive search function.

The message date, Category, Frequency, Time or Priority, and a partial message. The complete Message
is displayed in the Full Message box below.

The buttons at the bottom of the Archive Messages box allow you to Delete an archive message, Print the
list of messages, return to the Review Archive box to use different Search Options, or Cancel the search.

Related Topics

Delete an Appointment



Autostart

Autostart allows you to automatically start OnTime each time MS-Windows is loaded. If this option is on a 
check mark will appear to the right of the word Autostart

This feature may be enabled or disabled as desired by clicking on it.

Related Topics

Display Settings



Categories

All messages or appointments are placed into categories. Categories allow easy grouping of 
appointments. These groups may be selected for display and printing purposes.

OnTime comes with several built in categories, you may add up to a total of 30 categories by using the 
Category Maintenance functions.

Category Selection enables you to select which categories the Day Planner is to display.

Related Topics

Add an Appointment
Modify an Appointment
Print



Category Maintenance

This dialog box is opened by selecting Category Maintenance from the Category Menu. It is used to 
maintain categories and their appointments. It is here that you may create new categories, or modify 
existing ones.

All available categories are displayed in the Categories box on the left.

To add a new category click the Add button and enter the new category name and abbreviation.

To modify an existing category select the desired category from the box on the left and click the Modify 
button. You will be prompted for the modified name and abbreviation.

Delete will remove the selected category and all appointments in it. Before you use this option make sure 
you no longer need these appointments, or that you have transferred them to another category.

To transfer appointments from one category to another click the Transfer button. You will be prompted for 
the category to transfer from and the category to transfer to.

Once your maintenance is complete, click the Ok button to close the dialog box.

Related Topics

Categories
Category Selection



Category Selection

To set up the categories to be displayed by the Day Planner selected mode use this option. Selected 
mode displays a mixture of categories that you select.

The Selected Mode Categories box displays all available categories in a box on the left. This box is 
opened by selecting Selected Mode Categories from the Category menu. You may select or deselect any 
of these either by clicking the mouse cursor on it, or by clicking the Select and Remove buttons.

Clicking the Select All button will select all categories.

Click the Ok button when your selection is complete.

Related Topics

Categories
Category Maintenance



Clipboard

The Clipboard is a MS-Windows function that enables copying and moving data across programs and 
Windows screens.

OnTime uses the clipboard in two ways. It may be used as a means of rescheduling an appointment by 
highlighting a message and selecting Cut or Copy from the Edit Menu. Cut removes the message and 
places it in the clipboard, Copy makes a copy into the clipbaord and leaves the original message intact. 
The message remains in the clipbaord until it is Pasted into its new location.

The OnTime notepad uses the Clipboard as a means of moving and copying data. Refer to you MS-
Windows documentation for details on using this function.

Related Topics

Notes



Color Customization

You may customize most of OnTime's screen colors by selecting the Colors option from the Options Menu
to open the OnTime Color Scheme dialog box.

Here you may select or modify a color scheme. Once you have selected a color scheme from the drop 
box click the Ok button. Click the Cancel button to ignore changes and exit the dialog box.

To edit a color scheme click the Edit Scheme button. The OnTime Custom Color Scheme box displays a 
palette of available colors to the right. The left of the box shows a small simulation of the OnTime screen 
so that you may see your color changes take effect.

To change any of the screen colors, you must first select the item you wish to change from the Selected 
Screen Element list or click on it in the simulated screen on the left. You may then click on the desired 
color in the color palette and click the assign key.

To change the palette colors click on the color to change and then click on the Custom Colors button. You 
will then be able to adjust the red, green, and blue ration within that color. This way you have endless 
combinations of colors available.

To reset the colors to their default color set, click on the Default button. To accept your new color set click 
the Ok button. Click Cancel to ignore the changes made.

Related Topics:

Appointment Settings
Display Settings
Font Selection



Date Selection

There are several ways to select a date. Clicking the  and 

 buttons on the bottom left of the screen will take you back or forwards one day at a time. The Today 
button quickly returns you to Today's date.
You may also click on any date in the three calendars at the bottom right of the screen. The center 
calendar shows the currently selected month. The other two calendars are the month before and after the 
currently selected month.
The Select Date button (both at the bottom of the screen and in some dialog boxes) displays the Select 
Date dialog Box. This box displays a set of calendar cards. You may select any card by clicking on it. 
Likewise a date may be selected by clicking on it. Move through the calendars by clicking on the Month 
and Year selection buttons. Click Today to return immediately to Today's date. After having made your 
selection, click Ok to go to the new date.
Related Topics

Time Selection



Day Planner

The Day Planner is the focal point of the OnTime screen. It displays all your appointments and to-do lists 
for any given day.

The Day Planner is divided into several areas. Briefly these are:

The Menu bar at the top gives you access to OnTime functions and help.

The days events or to-do lists are displayed in the appointments area. Appointments with an attached 
Alarm have the alarm symbol  to their left. Events marked as critical have a 

 to their left. Appointments with attached Notes are bent over at the top right corner. You may click here 
to view or modify the note.
Above the appointments area are buttons that allow you to select the Category of appointments or 
messages you wish to see. You may select, Appointments, Non-Appointments, Selected categories, or All
categories. Selected categories are a combination of categories that you may set up with the Category 
Selection function.

The grid on the right displays a graphic view of allocated time. Time in use is blocked out. Current time is 
also marked with a block. In this area the mouse cursor becomes a magnifying glass as displayed on the 
left. By clicking this cursor over any blocked out time span, the messages attached to that time will be 
displayed.

The bottom left of the screen contains buttons that enable control and manipulation of your calendar. Click

 to go back a day, 

 to go forwards a day. Today will return you immediately to Today's date.
Click Add to Add an Appointment, Modify to Modify an Appointment, Delete to Delete an Appointment, and
Reschedule to Reschedule an Appointment. Click the Select Date button to access the Date Selection 
dialog box. To perform a Keyword Search click the Search button.

The Print button will display the Print menu.

The Week button will display the Week Grid.

The Month button will display the Month Grid.

The bottom of the screen displays three calendars. The currently selected month is displayed in the 
center calendar. The previous month is to the left, and the next month is to the right. You may click on any
day in these calendars to go to that date.

Related Topics

Display Settings



Mouse



Delete an Appointment

When appointments or messages are no longer needed they may be deleted. To delete an entry it must 
first be highlighted. Then either click on the Delete button or select Delete from the Edit Menu.

If the record to be deleted is not a recurring record the Delete Record dialog box will appear. You are then
able to select whether or not you wish to Delete this record, and whether or not you wish to Archive it for 
future reference.

If the record is a recurring record you will be prompted as to whether you want just this occurrence 
deleted, all occurrences, or all future occurances.

Related Topics

Add an Appointment
Modify an Appointment
Reschedule an Appointment



Display Settings

OnTime allows you to customize the way it displays your information. Select Display from the Options 
Menu to open the Display Settings dialog box to make these changes.

You may wish to view your Week Grid immediately upon entering OnTime. To do so, click the check box 
marked Display Week Grid First on. You may click this box again to turn this option off. To increase your 
message area size in the Day Planner screen you might wish to turn off the Appointment Grid. You may 
do so by clicking on the Display Appointment Grid check box. Click there again to turn this option back on.

Owner Name is the name of the OnTime user. This name appears to the right of the status line at the 
bottom of the OnTime screen.

You may also select the Default Category Mode. This option only sets the Category that the Day Planner 
screen displays when you start OnTime. Of course you may select any other Category for viewing while in
OnTime itself.

There are two orders in which OnTime can display messages. Select either Category or Priority by 
clicking the button to the left of the desired order.

The format that dates are displayed in may be either Standard or European. Select the format you wish 
by clicking the button to the left of these options.

Time Format may also be customized. Select either Standard or Military formats.

Once your customization is complete click the Ok button to accept the settings. Click the Cancel button to 
discard your changes.

Related Topics:

Appointment Settings
Color Customization
Font Selection



Exit OnTime

Select this option to close OnTime.

Alarms will not sound if OnTime is closed. If you have an Alarm set to sound you will be prompted for 
confirmation before OnTime is closed.

Related Topics

File Menu Commands



Font Selection

You may change the size of the Day Planner font with this option. Select the size that is most comfortable 
for you to work with.

There are four sizes to choose from. Select either Small, Medium, Large, or the System default. As you 
make a selection you will see the selected size displayed. Selecting a smaller size will allow OnTime to 
display more information at one time.

Click Ok to accept the new size.

Related Topics:

Appointment Settings
Color Customization
Display Settings



Frequencies

Messages and appointments in OnTime may be single or recurring events. You tell OnTime the type of 
record you desire by selecting a frequency. This is done in the Add a Message, or Modify a Message 
dialog boxes.

OnTime supports these frequencies:

Single Records that appears only once.
Weekly Records that will appear weekly on the selected day.
Bi-Weekly Records that will appear every 2 weeks on the selected day.
Monthly Records that appear each month on the selected day.
Quarterly Records that appear every 3 months.
Semi-Annual Records that appear every 6 months.
Yearly Records that appear on a given date every year.
Auto-Rollover Non-appointment records that start appearing on the date specified, and roll over 

every day until they are deleted or archived.
Variable Days # may be any number of days between 1 an 255. (Eg. every 3rd day would be 

N3).

Some frequencies require additional parameters. You will be prompted for these when needed.

Related Topics

Add an Appointment
Modify an Appointment



Keyword

Keywords are words, up to the first 15 characters, of any Message. Performing searches on keywords 
rather than on full messages is considerably quicker.

You might want to establish a system whereby the keyword section of the message contains information 
that would allow easy search and retrieval. Perhaps always put the contact name at the beginning of the 
message. This way you could search for all references to that contact name.

Related Topics

Keyword Search
Review Archive



Keyword Search

To locate a message anywhere within OnTime use the Keyword Search function. To do this either click 
the Search button at the bottom of the Day Planner screen, or select Keyword Search from the Edit Menu.

Use the OnTime Keyword Search dialog box to set up your searches, and to view the results. Enter the 
text to search for in the Search For field. You may then select whether to search Keywords only, or the 
Full Message. To perform a Case Sensitive search click the Case Sensitive check box on. When you 
have set up the search click the Search button to conduct the search.

The partial retrieved messages, their dates, times, and frequencies are displayed in the Messages for 
Keyword box. The Full Messages text is displayed in the box to the right.

You may highlight any of these messages and click on the buttons at the top right to perform several 
functions. Click Modify, Delete, or Reschedule to manipulate the highlighted message. Click Add to Add 
an Appointment. To print the retrieved messages click the Print button.

Click Goto Selected Date to go to the date of the highlighted message.

Related Topics

Delete an Appointment
Modify an Appointment
Reschedule an Appointment



Message

The message area of an appointment or to-do list entry may contain up to 80 characters of text. This 
appears in the Day Planner, and Week Grid and Month Grid detail views, and on all reports.

The first 15 characters of the message area is that message's Keyword,

If more than 80 characters are required you will have to attach a Note.

Related Topics

Add an Appointment
Keyword Searches
Modify an Appointment
Review Archive



Modify an Appointment

There are several ways to modify an appointment or message. One way is to highlight the desired 
appointment in the day planner and click the mouse button or press enter. Alternatively you may click the 
Modify button at the bottom of the screen, or select Modify from the Edit Menu.

Any of these options will open the Modify A Message dialog box.

If the appointment is a recurring event you will be prompted as to whether to modify this ocurrance, all 
occurances, or all future occurances. Make your selection and then select Ok, or click Cancel to stop the 
modification.

Here you may modify a Message, use the Category Selection to select a Category, select a Frequency, a 
Priority if it is a non-appointment, modify the starting and ending dates, appointment time, and Alarm time.
Click on the Select Date button for help with Date Selection. The Select Time button assists you in Time 
Selection. You may also add or modify a Note by clicking on the Add Note or Modify Note button

After having entered the required information, click the Ok button to save the modified appointment. Click 
Cancel to stop this procedure.

Related Topics

Add an Appointment
Delete an Appointment
Reschedule an Appointment



Month Grid

The Month Grid displays time usage for a month at a time. Time that is allocated is blocked out. and may 
be viewed in detail if desired. To get to the Month Grid click the Month button at the bottom of the Day 
Planner or Week Grid screens.

To view any allocated time block in detail, move your mouse cursor into the Month Grid. The cursor will 
turn into a magnifying glass as displayed on the left. Position the cursor over any blocked out time slot 
and hold down the mouse button. The time usage in detail will be displayed.

The Print button will display the Print menu.

The Day button will display the Day Planner.

The Week button will display the Week Grid.

Related Topics

Date Selection
Mouse



Notes

OnTime allows you to attach Notes to appointments and messages. A record with a note attached is 
displayed in the Day Planner as folded over in the top right corner. To view or modify the note click on this
fold.

The Note dialog box displays the message in the upper window, and lets you attach a note in the lower 
window. The menu bar at the top has three options. The File menu is used to save or print your note, and 
Printer Setup. The Edit menu contains Clipboard functions, an Undo command to undo the last change 
made, and an option to enable or disable word wrap. The Search menu allows you to search your note for
specific text.

Related Topics

Add an Appointment
Modify an Appointment



Print Preview

OnTime allows you to view your reports on the screen. To do this click the Preview button available from 
the print dialog boxes.

You may then choose to zoom in and see the report in detail, or zoom out to see the whole report at once.
You may move the report on the screen with the hand cursor shown on the left. To print the report directly 
from within the preview window, click the Print button.

Related Topics

Printing
Printer Setup



Printer Setup

Before you can print reports you must have installed and selected a printer. Selecting Printer Setup from 
the File Menu will list your installed printers. Select one of these and click the Ok button. To open the MS-
Windows printer setup dialog box click the Setup button.

This dialog box is specific to each printer. Make your selections and then click Ok to accept them.

Related Topics

Print Preview
Printing



Printing

OnTime prints attractive and highly useful reports. Clicking on the Print icon, or selecting Print from the 
File Menu displays a menu of available reports.

Select the report you wish to print to open that reports dialog box. You will be presented with buttons 
allowing you to Print or Cancel.

If you are printing a Week Grid, Month Grid, or Tri-Fold Print, you will also be able to preview the report on
the screen. Click the Preview button to use this function.

Most reports are highly configurable. Pressing the Options button in those dialog boxes that have one will 
allow you to customize the reports. Some options are page orientation, paper source, typeface size, page 
margins, and number of copies. You may also customize columns, indentation, whether or not to print 
calendars and wrap text if applicable.

Related Topics

Printer Setup



Priority

Non Appointment messages may be assigned priorities. These are optional values, and you may sort 
your lists by priority if you wish.

Valid priority entires are 1-99 and A-Z. 1 is the highest priority, Z is the lowest. Leave the priority field 
blank if the message has no priority.

To sort by priority, select Priority for the Sort Order in the Display Settings dialog box.

Related Topics

Add an Appointment
Categories
Frequencies
Modify an Appointment



Reschedule an Appointment

There are several ways to reschedule an appointment. You may highlight the desired appointment and 
click the Reschedule button, or select Reschedule from the Edit Menu. You may also reschedule an 
appointment located with the Keyword Search, or use the Cut or Copy commands to use the Clipboard.

Any of these options will open the Reschedule dialog box. This box takes two forms. It can be a small 
single line box allowing you to see the screen beneath. By clicking the Show button the full dialog box will 
be displayed and you will be able to see the full appointment message. To reduce it again to the smaller 
size, click the Hide button.

The Reschedule dialog box prompts you for the date and time to move the appointment to. You may type 
this in the field, or simply select that day and time using regular Date Selection techniques.

Once you have selected the new date and time click the Reschedule button. You will be prompted as to 
whether or not you wish to delete the previous occurrence. 

Related Topics

Add an Appointment
Delete an Appointment
Modify an Appointment



Review Archive

Whenever an appointment is deleted OnTime will prompt you as to whether or not to Archive it. The 
Archive stores copies of deleted appointments and messages for future reference.

Selecting Review Archive from the Archive Menu displays the Review Archive box. Here you may select 
the archived messages you wish to review.

Date Options are used to narrow down the list of archived records. You may select All Messages, Todays 
Messages, Current Months Messages, or a Selected Date Range. If you choose a Selected Date Range 
you will be prompted for a starting and ending date.

If you wish to Search with keyword, click on this option in the Keyword Options area. You will then be 
prompted to enter the keyword, and select whether or not the search is case sensitive, and whether to 
search on keywords only. If you turn the Keywords Only option on, OnTime will only search up to the first 
fifteen characters of each message. This is quicker than a regular search.

You may also select which categories to search through. Either click on All Categories, or Selected 
Categories. If you choose the latter you will be able to select the desired categories in the box on the 
right.

Once you have made your selections, click the Ok button to display the Archive Messages box.

Related Topics

Delete an Appointment



Time Selection

Clicking on the Select Time button in the Add or Modify dialog boxes will display the Time Selection dialog
box. This enables quick and simple selection of appointment starting time and duration.

At the top of the box is a time grid. Already allocated time is marked blocked out at the bottom of the grid. 
To mark your appointment starting time drag the upper triangle to the desired time with the watch cursor 
as shown to the left and release the mouse button. Do the same with the lower triangle to set the ending 
time.

The entire block of time may be rescheduled by dragging it with the hands cursor as shown to the left.

These times may be set or adjusted using the fields below. You may enter a time in the correct box, or 
adjust it by clicking on the up and down arrows to the right of each field.

For a Notime appointment, click the Notime button.

Once time selection is complete click Ok to accept or Cancel to ignore settings.

Related Topics

Date Selection



Week Grid

The Week Grid displays time usage for a week at a time. Time that is allocated is blocked out and may be
viewed in detail if desired. To get to the Week Grid click the Week button at the bottom of the Day Planner
or Month Grid screens.

 To view any allocated time block in detail, move your mouse cursor into the Week Grid. The cursor will 
turn into a magnifying glass as shown to the left. Position the cursor over and blocked out time slot and 
hold down the mouse button. The time usage in detail will be displayed.

The Print button will display the Print menu.

The Day button will display the Day Planner.

The Month button will display the Month Grid.

Related Topics

Date Selection
Mouse



Commands

The OnTime menus are:
File Menu
Edit Menu
Options Menu
Category Menu
Archive Menu

Relate Topics
Procedures



File Menu Commands
The File Menu contains options that allow printing and printer setup, and autostart capability.

Printer Setup
Print
Autostart
Exit OnTime

Related Topics
Archive Menu Commands
Category Menu Commands
Edit Menu Commands
Options Menu Commands



Edit Menu Commands
The Edit Menu contains options for adding, and manipulating appointments and messages, 
and keyword search.

Add
Modify
Delete
Reschedule
Cut
Copy
Paste
Delete
Keyword Search

Related Topics
Archive Menu Commands
Category Menu Commands
File Menu Commands
Options Menu Commands



Options Menu Commands
The Options Menu is used to modify system settings, colors, fonts, and display options.

Appointment Settings
Display
Colors
Fonts

Related Topics
Archive Menu Commands
Category Menu Commands
Edit Menu Commands
File Menu Commands



Category Menu Commands
The Category Menu is used for category selection and maintenance.

Appointments
Non-Appointments
Selected Mode
All Categories
Category Maintenance
Selected Mode Categories

Related Topics
Archive Menu Commands
Edit Menu Commands
File Menu Commands
Options Menu Commands



Archive Menu Commands
The Archive Menu gives you access to archived messages and appointments.

Review Archive

Related Topics
Category Menu Commands
Edit Menu Commands
File Menu Commands
Options Menu Commands



Keyboard

Use the following keys in OnTime:

Key Function

Right Arrow Advance OnTime one day
Left Arrow Go back one day
Home Return to Todays date
Up Arrow Up one message
Down Arrow Down one message
PgUp Top of calendar
PgDn Bottom of calendar
Shift-Up Arrow Up one line in time grid
Shift-Down Arrow Down one line in time grid
Shift-PgUp Top of time grid
Shift-PgDn Bottom of time grid
Ctrl-D Date stamp in message area
Ctrl-T Time stamp in message area

Related Topics

Mouse Cursors



Mouse Cursors

Depending on which screen you are in, and what operation you are performing, OnTime uses different 
mouse cursors for different purposes.

The magnifying glass cursor is displayed when you move your mouse into any of the time allocation 
areas. These are the grid on the right of the Day Planner, the Week Grid, and the Month Grid.

The watch cursor is used to mark appointment starting and ending times in the Time Selection dialog box.
You may move it right or left to mark the desired time.

The hands are used to move an appointment in the Time Selection dialog box. You may move it right or 
left to the desired time slot.

This single hand cursor is used to move the Print Preview screen.

Related Topics

Keyboard



Procedures

The Index lists all OnTime procedures. This is not the complete Index. Use the scroll bar to see entries 
not currently visible in the Help Window.

Procedures
Add an Appointment
Appointment Settings
Archive
Autostart
Category Maintenance
Category Selection
Color Customization
Date Selection
Delete an Appointment
Display Settings
Font Selection
Keyword Search
Modify an Appointment
Print Preview
Printing
Reschedule an Appointment
Time Selection

Related Topics
Commands


